Multiplayer: Host antwortet nicht - Lösung!

    • [NTW]

    Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

    Vom 7. bis 10. Juni geht es zum Forentreffen nach Frankfurt. Kurzentschlossene können jederzeit noch teilnehmen. Klick mich fest
    • Multiplayer: Host antwortet nicht - Lösung!

      Hallo ihr lieben TW´ler,

      habe hier einen Lösungsweg für das bekannte Problem, bei dem der Host angeblich nicht antwortet, wenn man versucht zu diesem zu connecten ( Host antwortet nicht ).

      So wie es scheint, tritt dieses Phenomen hauptsächlich bei Leuten auf, die einen Router benutzen. Dies lenkt den Verdacht bzw. die Ursache für dieses Problem auf die interne Firewall des Routers.
      Ich selbst nutze einen Speedport w 701v (ohne UPnP) und hatte bisher nicht wirklich schwierigkeiten bei anderen Spielern zu joinen, bzw. es gab bisher auch noch keine wirklichen Schwierigkeiten, dass man bei mir joinen konnte.
      Irgendwann jedoch kamen zwei Freunde, die zufälliger Weise beide den gleichen Router haben, EasyBox von Vodafone. Jedenfalls haben bei beiden bisher die bekannten Ports, die man so online findet nicht gefruchtet und es kam immer die Meldung Host antwortet nicht.

      Nach langen Nachforschungen haben wir nun herausgefuden woran es lag. Es gab einen Port, den wir bisher noch nirgends im Netz gefunden haben.

      Also, hier die lang erwarteten Ports:

      TCP 27015, 27020 bis 27050, 49181
      UDP 1200, 27000 bis 27020

      und

      --->>> UDP 51914 <<<---

      Nun kann mein Freund bei so ziehmlich allen Joinen und glücklicher Weise für so ziehmlich Jederman hosten. Vorraussetzung ist jedoch, dass beide Spieler, Hoster und Joiner, diesen Port UDP 51914 offen haben.

      Also, wir möchten uns an dieser Stelle nochmal recht herzlich beim CA Support bedanken, der uns in keinster Weise geholfen hat und die MultiplayerSpieler so vernachlässigt. Auch einen herzlichen Dank an Sega für die Nicht-Unterstützung!

      Ich/wir hoffen, dass dies einigen von euch helfen wird bei anderen zu joinen, bzw. endlich selbst hosten zu können.


      MFG
      Pushi
    • Du/Ihr wisst nicht zufällig, ob man diese Lösung auch auf andere TW-Spiele, wie Rome oder Medieval: 2 übertragen kann?
      Also, wir möchten uns an dieser Stelle nochmal recht herzlich beim CA Support bedanken, der uns zu keiner Weise geholfen hat und die MultiplayerSpieler so vernachlässigt. Auch einen herzlichen Dank an Sega für die Nicht-Unterstützung!
      Oh ja, dies kommt mir irgendwie bekannt vor.
    • Also wir haben es eben bei ETW getestet mit allen Ports die oben aufgeführt sind und es geht bei ETW nicht. Welche anderen Ports man für ETW evtl. benötigt haben wir bisher noch nicht nachgeforscht.

      Auf diesen besagten UDP Port sind wir auch nur ganz zufällig gestoßen, als SGDE das Spiel Napoleon gestartet hat und bei mir, ohne das er mir eine Einladung geschickt hat, eine MSG von Steam kam, die wie folgt lautete:
      S.G.D.E. spielt jetzt Napoleon: Total War. Zum Einklinken hier klicken.

      Als ich auf diesen Link geklickt hatte, öffnete sich ein neues Fenster und da kam folgende Nachricht mit folgender IP und folgendem Port (siehe Bild) :

      24.167.12.188:51914

      Also, sofern ihr mal durch zufall auch solch eine Nachricht bei ETW erhalten solltet, dann bitte diesen Port unbedingt Posten. Auch wenn er nirgends aufgeführt wird, so werden eben diese Ports ebenfalls benötigt.
    • Danke, daß Ihr euch die Mühe gemacht habt, dieses Problem und v.a. auch die Lösung zu schildern.
      Leider spielt hier so gut wie niemand weder ETW noch NTW im Multiplayer, aus welchen Gründen auch immer. Viele haben ja das Spiel, aber die Luft ist bei den meisten raus ( oder war nie drin..... ).
      Hätte mir gerade in Anlehnung an den Forennamen eher eine NTW-League gewünscht als das Käfergewusel, ist aber leider so.


    • Mogges schrieb:

      Hätte mir gerade in Anlehnung an den Forennamen eher eine NTW-League gewünscht als das Käfergewusel, ist aber leider so.
      Es gab immerhin 2 Runden eine erfolgreiche TWL-League. Die einzige die mir in M2TW bekannt ist. Und mit dem TWZ zusammen gab es auch die Champions League, die Twiggles gewonnen hat. ;notice:
      Aber NTW, naja, ... ich glaueb 'Icebear und Lion spielen abundzu noch online, aber die meisten nicht.
    • Nein, online kann ich aus dem hier beschriebenen Fehler nicht spielen. Weder ETW noch NTW. Und ja, ich habe die Ports alle einmal freigeschaltet gehabt und auch sonst so ziemlich alles mögliche ausprobiert. ;)

      :) Wer sich zu groß fühlt, um kleine Aufgaben zu erfüllen, ist zu klein, um mit großen Aufgaben betraut zu werden. :)
    • mit wem hast du dich denn versucht zu connecten? wenn der den port nicht offen hat , den besagten dann kannst so lange probieren bis dir der arsch abfällt!
      was hast du für einen router?

      und das ETW nicht auf die weise funktioniert war schon geklärt!

      meine frage wegen deinem router ist begründet, wenn er eine einstellungsmöglichkeit für spezielle anwendungen hat musst du den 51er port da als trigger und public port freigeben.
      viele router gehen heute nur übers portmapping direct was heist udp/tcp freigaben aber wie bei mir und ein paar anderen meiner bekannten zbs. muss man auch noch über trigger und public frei geben.
      und das hat bei allen wunderbar funktioniert!

      ansonnsten schau mal in deiner software firewall nach, falls vorhganden, ob da nicht irgend was geblockt wird!
    • SGDE schrieb:

      mit wem hast du dich denn versucht zu connecten? wenn der den port nicht offen hat , den besagten dann kannst so lange probieren bis dir der arsch abfällt!


      Wenn 30 andere zu dem connecten können, dann kann es nicht an ihm liegen. Und wie gesagt, freigegeben habe ich wirklich alles.

      wenn er eine einstellungsmöglichkeit für spezielle anwendungen hat musst du den 51er port da als trigger und public port freigeben.


      Hat er nicht.

      :) Wer sich zu groß fühlt, um kleine Aufgaben zu erfüllen, ist zu klein, um mit großen Aufgaben betraut zu werden. :)
    • @SGDE:
      In unserem Forum achten wir sehr auf Rechtschreibung, Groß-/Kleinschreibung und Grammatik, denn so kann man Texte deutlich besser lesen und verleiht dem ganzen Post einen besseren Ton.
      Wäre also schön, wenn du bei deinen nächsten Posts einen Satzanfang mit Großbuchstaben anfängst ;)
      Am besten ist es, wenn man den Beitrag vor dem Absenden noch einmal in der Vorschau durchliest, so kann man einige Fehler vermeiden.

      Fühl dich durch den Post jetzt nicht angegriffen, wir müssen das vielen Neuen sagen :cool:

      Ansonsten bleibt mir nur noch zu sagen :welcome:
    • Okidoki,


      es ist bedauerlich, dass du dennoch nicht zu anderen connecten kannst.
      Du könntest mal folgendes probieren, allerdings wirklich nur vorrübergehend, da du sonst die Hosen für alle im Netz herunter lässt:
      Alle Ports im Router freischalten. Oder zumindest alle im Adressbereich von 10000 - 65000 tcp/udp. Wenn es dann immernoch nicht funktioniert, dann liegt der Fehler vielleicht an der Art der Freischaltung (public, private, trigger, spez. Anwendungen). Sollte es jedoch nach dem Öffnen so ziehmlich aller Ports funktionieren, dann scheint es wohl doch noch einen oder mehrere Ports zu geben, die man öffnen müsste.

      Wenn du WIndows 7 hast, oder vielleicht geht das auch bei Win Xp, kannst du, wenn du das Spiel Napoleon gestartet hast und einen Server veranstaltest (also einen Server aufmachst) in der Eingabeaufforderung CMD folgendes eingeben:
      netstat -a -b -n

      Daraufhin werden dir fast alle Ports angezeigt, die von den jeweiligen .exe Anwendungen verwendet werden. Mir werden so bei der Napoleon.exe folgende Ports angezeigt:
      UDP 27016 und UDP 51914

      Wenn du magst, kannst du mich/uns auch auf unserem ts3 Server besuchen kommen und nach Pushi/Alex oder Sgde/Kai fragen. Wir sind so ziehmlich jeden Tag online. Unser TS findest du hier: 89.163.167.186:10209 pw: 123456


      grüße Pushi



      edit:

      ps: Ehe ich den besagten udp Port bei Napoleon geöffnet hatte, konnten auch so ziehmlich alle bei mir connecten, nur eben Sgde und sein Kumpel nicht.
    • Hi,
      Ein Freund von mir hat das Problem das er in keine Server kommt, wenn er joint kommt: Host antwortet nicht. Nun hab ich ihm das hier gezeigt, doch er und ich wissen nicht viel mit den Zahlen da anzufangen. Also was genau muss er wo eingeben, bei Daten, NAT oder Spezielle Anwendungen ?

      TCP 27015, 27020 bis 27050, 49181UDP 1200, 27000 bis 27020

      und

      --->>> UDP 51914 <<<---


      :help:

      Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von DerGroseKArantukki ()

    • Gerngeschehen :)
      Anscheinend hat keiner eine Antwort auf euer Problem gewusst, schließlich sind wir nicht allwissend. Du könntest aber so freundlich sein und die Lösung hier bitte posten, falls das Problem noch bei jemand anderen auftaucht und damit beitragen, dass sowas, wie in deinem Fall, nicht mehr passiert.
    • Sorry, ich bin selber leider nicht so aktiv hier im Forum, deshalb habe ich jetzt erst gelesen, was du vorigen Monat geschrieben hast.
      Ich wusste nicht, dass man evtl eine Anleitung benötigt, wie man Ports in der Firewall des Routers freischaltet.
      Solch eine Anleitung zu geben ist ohnehin schon recht schwierig, da sich die Router-Einstellungen alle von Router zu Router unterscheiden.
      Zunächst einmal muss man sich im Router einloggen, dazu benötigt man die Netzwerk-Router-IP.
      In der Regel ist das die 192.168.1.1, oder 192.168.2.100.
      Feststellen welche Router ip man im Netzwerk hat kann man indem man die Konsole von Windows öffnet. Also man klickt auf "Start" -> "Ausführen" und trägt dort "CMD" ein. Dann sollte sich die Konsole öffnen. Wenn man nun den Befehl "nslookup" eingiebt erhält man die IP des Routers. Diese trägt man nun beim Internetexplorer oder sonstigem Browser in die Adresszeile ein. Dann steht in der Adresszeile ungefährt sowas: 192.168.0.1

      Nun sollte sich ein Router-Verwaltungsfenster öffnen. Hier muss man nun Routerpasswort und Benutzername eintragen. In der Regel findet man das Passwort auf der RÜckseite des Routers. Andernfalls kann man auch mal folgende Nutzernamen:
      admin, Admin, Root, root, mit folgenden Passwörtern probieren: 0000, admin, password, 1234, root, toor.

      Nachdem man sich erfolgreich in den Router eingelogt hat, muss man in die Routerfirewall kommen, um die oben genannten Ports freischalten zu können. Leider ist das hier von Modell zu Modell unterschiedlich. Am besten man sieht im Handbuch nach. Sowas wir NAT/Firewall/PortForwarding/PortTriggering/PortMapping wird gesucht. Dort muss man dann Öffentliche und Private Ports bezogen auf Netzwerk-IP-Adressen eintragen.
      Wenn der Spiele-Computer bspw. die Netzwerk-IP 192.168.1.100 hat, so trägt man diese dort ein. Die privaten und öffentlichen Ports sind die, die ich oben genannt habe. Vermutlich muss man mehrere Einträge - mehrere NAT/Firewalleinträge - vornehmen.

      Wahlweise kann man auch mal versuchen eine Einstellung zu finden, die UPnP heist. Diese könnte man mal aktivieren, bei manchen funktioniert es dann auch, ohne dass man die Ports noch zusätzlich eintragen braucht.
      Wenn alles nicht fruchtet gibt es bei manchen Routern noch die Möglichkeit den DMZ-Mode zu aktivieren. Das bedeutet dass alle Ports geöffnet werden und der Router im Grunde alles durchlässt. Das stellt aber ein Sicherheitsrisiko für den jeweiligen PC, der da drann hängt, dar. Also sollte man das tunlichst vermeiden. Jeder geöffnete Port im Router ist im ürbigen ein Sicherheitsrisiko.

      Also langer Rede, kurzer Sinn. Im Routerhandbuch steht ziehmlich genau, wie man die Ports, den DMZ-Mode und UPnP aktiviert, wenn sowas unterstützt wird.

      mfg
      Pushi
    • Hilfe Multyplayer Problem

      :jumping2: Hallo Leute
      Ich habe mir jetzt schon sehr viele Beiträge durchgelesen aber komme nicht weiter...ich kann einfach nicht mit meinem Kumpel Online spielen -.-! ich habe eine Easybox 602 und er eine von Alice...Ich habe schon die Firewall komplett ausgemacht und irgendwelche ports probiert freizuschalten.ich habe ein Screenshot von gemacht...vielleicht könnt ihr mir ja helfen das wäre echt super !
      ich sage schonmal danke :)

      :pc:
    • RE: Hilfe Multyplayer Problem

      Mossi7788 schrieb:

      :jumping2: Hallo Leute
      Ich habe mir jetzt schon sehr viele Beiträge durchgelesen aber komme nicht weiter...ich kann einfach nicht mit meinem Kumpel Online spielen -.-! ich habe eine Easybox 602 und er eine von Alice...Ich habe schon die Firewall komplett ausgemacht und irgendwelche ports probiert freizuschalten.ich habe ein Screenshot von gemacht...vielleicht könnt ihr mir ja helfen das wäre echt super !
      ich sage schonmal danke :)

      :pc:


      Hi,

      es sind zwar mittlerweile mehr wie 6 Monate vergangen, und ich gehe auch nicht einmal mehr davon aus, dass du dir das hier noch durchlesen wirst, aber dennoch gebe ich dir eine Antwort:

      Laut deinem Bild kannst du bei deinem Router den Privaten Lanport und den Öffentlichen Port eingeben. Die Portnummern die von Lan nach Öffentlich und zurück gehen müssen die selbe Nummer haben. Bsp. LanPort TCP 1234 Öffentlicher Port TCP 1234

      Dein Privater LanPort 27000 zeigt bspw. auf den Öffentlichen Port 49181. Sowas funktioniert i.d.R. nicht bei Spielen.