[M2TW] Systemabsturz nach Modding

    Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

    • [M2TW] Systemabsturz nach Modding

      Hi
      Ich habe die Standard-Kampagne mit Geo-Mod ein wenig verändert und
      spiele über Bare Geo-Mod. Die installierte Version ist 1.3. Die
      Veränderungen (Neue Region innerhalb des HRR erstellt, die dem HRR
      gehört, alle Familienmitglieder dorthin verschoben, alle anderen Region
      dem Rebellen gegeben, paar Gilden in die Städte gepackt) funktionieren
      eigentlich einwandfrei und sind spielbar, bis zu einigen Runden das
      Spiel abstürzt. Dies geschieht v.a. bei Klicken auf bestimmte Agenten
      (wie später im log zu sehen) oder bei Schlachten gegen gewisse
      Charaktere oder Städte. Diese sind stets unterschiedlich: mal Rebellen,
      mal war's der Kronprinz von Schottland, mal die Städte Krakau und Thorn
      (an den Städten sieht man, dass das Spiel mitunter recht lange
      funktioniert).
      Weiß jemand zufällig Rat?

      komplettes log
    • Thread an der richtigen Stelle eröffnet, richtige Benennung und Log angehängt....zu vorbildlich, von wem bist du der Doppelaccount? :D :welcome:

      Wenn die Crashes so unterschiedlich auftreten ist es natürlich sehr schwierig rauszufinden woran der Fehler liegt, hast du denn noch weitere Änderungen abseits davon vorgenommen? Ansonsten kann ich eigentlich nur dazu raten Änderungen nur Stufenweise in kleinen Schritten durchzuführen und dann auch immer zu testen. Ist zwar umständlich, aber wenn sich irgendwo zwischendrin ein Fehler einschleicht lohnt sich das allemal. Und natürlich sollten dann auch immer Backups zu vorherigen Versionen angelegt werden.
      Ich persönlich würde außerdem nicht mit Geo-Mod arbeiten, dass Tool ist sicher gut, keine Frage, aber alle Änderungen die ich damit machen kann, kann ich auch von Hand machen und irgendwie hab ich dann auch einen besseren Überblick. Ist aber wie gesagt ne persönliche Ansichtssache, ich vertraue da einfach ungern in ein zusätzliches Tool.
    • So schwer war das nicht, wenn man des Lesens mächtig ist. ;)

      Edith sind noch weitere Änderungen aufgefallen, die ich vorgenommen habe: Generäle rekrutieren (direkt in der buildings-Datei), eine Stadt habe ich noch ein Stückchen verschoben und einige Burgen in Städte umgewandelt (beides mit Geomod). Das dürft's dann wirklich gewesen sein.
      Ich denke, dass ich es hinbekommen würde einen Großteil der Änderungen direkt in den Dateien vorzunehmen, aber ich hätte absolut keine Ahnung, wie ich eine neue Region nur in den Textdateien integrieren kann. :grübel: Das Schlimme ist ja, dass die Spiele mitunter wirklich lange laufen, daher könnte es etwas nervig werden, jeden Schritt einzeln vorzunehmen, um zu sehen, woran es liegt. ;(

      Dieser Beitrag wurde bereits 2 mal editiert, zuletzt von Soulreaper ()

    • Ja, das Hauptproblem ist bei dir wohl wirklich, dass das Spiel so lange läuft ohne das der Fehler auftritt. Aber gut, man kann ja relativ schnell durchklicken. Am besten wäre es hier wirklich von vorne anzufangen, die Anzahl der Änderungen ist ja auch nicht derart groß.
      Wenn du Geomod für die Provinzen nicht verwenden willst, dann kannst du dir auch dieses Tutorial anschauen: Erschaffung einer neuen Provinz (M2TW)
    • Puh, ich wusste ja, dass man viel Geduld fürs Modden mitbringen muss, aber langsam glaub ich dann doch zu blöd dafür zu sein. Ich hab jetzt mal sicherheitshalber das Spiel entfernt und neu installiert. Anschließend habe ich es wieder auf 1.3. gepatched und die Dateien entpackt, um dann den von dir oben verlinkten Weg auszuprobieren. Gesagt, getan, alle Änderungen wie im Tutorial vollzogen (nur halt in einer anderen Provinz) und gestartet. Das Ergebnis war ein unbestimmter Fehler und Systemabsturz. Ins log geschaut, das mir mitteilte, das die Region in der string-Datei nicht gefunden werden kann. Da wundere ich mich doch, was die string-Datei noch für eine Rolle spielen kann, wenn ich mit medieval2.exe --io.file_first starte, da er auf die txt-Dateien zugreifen soll?! :grübel:
      Nun gut, dann eben mit dem Bin-Editor, der beim Geomod oder BareGeomod dabei war die Region auch noch in die String-Datei geschrieben. Spiel neu gestartet, wieder 'nen Absturz rausgekriegt, nur mit anderen Gründen im log. Ich poste mal die letzten Zeilen, da ich das gesamte log gerade nicht hochladen kann (Inetverbindung nur übers Smartphone grad).

      Edith sagt: log wieder gelöscht - nach einigem hin und her habe ich es nun doch geschafft eine Region einzubauen. Ein erster Teilerfolg, der wird jetzt gefeiert. :sauf: Woran es genau lag, kann ich nicht sagen. Ich habe die string.bins jetzt einfach mal so gelassen wie sie sind und nur die imperial_campaign_regions_and_settlements_names.txt aus einem anderen Forum runtergeladen. Danach dann eben die entsprechenden Dateien erneut verändert. Nun läuft's fürs erste.

      Dieser Beitrag wurde bereits 2 mal editiert, zuletzt von Soulreaper ()

    • Änderungen am besten nie im Hauptordner des Spiels vornehmen, sondern in einem Mordordner, Bare Kingdoms ist ja nichts anderes. Wobei ich persönlich lieber mit retrofit als Grundlage anfange. Ich würde auch nicht die string.bin Dateien direkt bearbeiten, sondern diese in Textdateien konvertieren und erst dann bearbeiten. Ist auf Dauer auch einfacher.
      Naja, aller Anfang ist schwer, das Spiel ein bisschen zu schrotten gehört irgendwie dazu ;)
    • In einem Mordordner? :D
      Ja, hab zunächst auch in Modordnern gearbeitet, das Spiel war aber irgendwie so verkorkst, dass ich mal lieber neu installiert habe. Doch selbst dann gab's ja erst noch Probleme. Ich hab die Dateien ja auch entpackt und den io-Befehl verwendet, daher hat mich die Fehlermeldung mit den string.bin im log ja so sehr verwundert, da er auf die ja gar nicht zugreifen sollte, dachte ich?! Erst danach hab ich mal direkt die string.bin verändert, um zu sehen, was so passiert.
      Das mit der neuen Region scheint nun endlich gut zu klappen. Mal ne kurze Kampagne durchgespielt und keinen Absturz gehabt. :jumping: Nun geht's auf zu neuen Ufern und damit wohl auch zu neuen Abstürzen. :thumbsup:
    • Das Problem wenn du im Spiel selber moddest ist halt das du dir eben auch das ganze Spiel zerballern kannst, bei einem Modordner kannst du um schlimmsten Fall einfach den Ordner löschen und das wars. Erleichtert auch das anlegen von Backups bei weitem. Und es ist besser die konvertierten Textdateien zu bearbeiten als die string.bin Dateien, nach meiner Erfahrung etwas weniger fehleranfällig. Musst halt nach der Bearbeitung sicherheitshalber die string.bin Dateien löschen damit diese neue erstellt werden können, sonst kann es passieren das Änderungen nicht übernommen werden und das führt dann wiederum zu Fehlern.
    • Keine Ahnung warum ich den Thread hier verpasst habe. Beim nächsten Mal bitte die TXT Datei komprimieren - dann kannst Du sie uU hier sogar anhängen.

      Der Fehler in Deinem Log tritt volle 6 Sekunden nach dem letzten Eintrag auf - eine Ewigkeit im Log und in diesem Falle gibt es keinen Anhalt was die Ursache ist.

      Tip für Geomod: neue\ bearbeitete Einträge validieren, ansonsten werden sie nicht in die Dateien geschrieben. Das ist wahrscheinlich bei Deiner Region geschehen. Wenn Dein englisch auf der Höhe ist, dann kann ich Dir meine Anleitung für Geomod empfehlen.

      Hier ein einfaches Modverzeichnis zum ausprobieren, ist Geomod tauglich.
    • Probleme beim Modden

      Hallo Zusammen,

      ich hängel mich momentan an der MOD-Anleitung von Alpi durch. Die Testfraktion mit Anjou hat auch wunderbar geklappt (naja okay beim 3ten Versuch gings dann irgendwie).

      Nun wollte ich ich anstatt Anjou<->Frankreich | deutsch Ritter<->Heiliges Römisches Reich einfügen.
      Soweit so gut. Also wie im tut die Einträge passend verändert.

      Bin jetzt bei Punkt 4. Die "Verfeinerung" angekommen und er spuckt mir sobald ich auf Große Kampagne klicke folgende "Fehlermeldung" raus.

      zuerst hab ich versucht alles zu kontrollieren, wobei ich aber gestehen muss, dass ich leicht den Überblick verloren habe. Daraufhin hab ich alles nochmal Widerholt. Am Ende jedoch kommt genau der gleiche Fehler.

      Habt ihr ne Ahnung woran das liegen kann bzw was ich falsch gemacht habe?

      Vielen Dank

      LG

    • Wo ist Gigantus wenn man ihn raucht? :D
      Der wüßte am besten woran es liegen könnte.

      Würde mal die text-Dateien nochmal prüfen, ob da auch alle Einträge vorhanden sind und auch die bat deiteien gebildet wurden. Wobei es bei nem Fehler dort wohl eher nen Crash oder nen fehlerhafte Anzeige geben würde.
      Alternativ mal die Einträge in der factions und strat genau ansehen, ob diese wirklich so sind wie sie sein sollten.
      Sonst bleib nur die Lösung immer wieder jeden Schritt zu überprüfen um herauszufinden wo der Fehler liegt.
      Meister des Schokimods


    • Warum hab ich den Thread erst jetzt gesehen und warum hat Ihn niemand ins Modding Forum geschoben? Fragen über Fragen, aber egal --->verschoben & :welcome:

      Hast du denn Sicherheitskopien von den vorherigen Schritten? Hast du mal geschaut ab welcher Veränderung der Fehler genau auftaucht?
    • Benutzer online 1

      1 Besucher